Diferencias

Muestra las diferencias entre dos versiones de la página.

Enlace a la vista de comparación

es:centro:servizos:ubuntu_14.04_citius [2018/01/08 14:42]
diego.cougil creado
es:centro:servizos:ubuntu_14.04_citius [2018/01/11 09:01] (actual)
diego.cougil
Línea 1: Línea 1:
-====== Sistema operativo Ubuntu ​14.04 CiTIUS ======+====== Sistema operativo Ubuntu ​16.04 CiTIUS ======
  
-Instalación,​ mantenimiento y soporte técnico de un sistema operativo Ubuntu ​14.04 modificado por el CiTIUS.+Instalación,​ mantenimiento y soporte técnico de un sistema operativo Ubuntu ​16.04 modificado por el CiTIUS. ​ 
 +===== Notificaciones y comunicación entre usuarios =====
  
-Puede solicitarse la instalación ​del sistema ​**en cualquier equipo conectado a la red de datos del centro** a través del [[https://​citius.usc.es/​dashboard/​enviar-incidencia|formulario ​de incidencias]].+Para comunicar problemas, dudas o hacer sugerencias,​ se empleará el canal ''#​ubuntu1604'' ​del Slack del CiTIUS. El sistema ​dispone ​de un applet ​de notificaciones para novedades sobre software, actualizaciones,​ etc. 
 +===== Software disponible =====
  
-===== Cómo instalar ​software ​adicional =====+El sistema cuenta con varios repositorios adicionales a los de la Ubuntu 16.04, con el siguiente ​software ​ya instalado por defecto:
  
-==== Matlab e Maple ====+  * Java 8 de Oracle 
 +  * Telegram, Scudcloud (Slack) 
 +  * Dropbox 
 +  * Skype 4.3 
 +  * Virtualbox 5.1
  
-Matlab y Maple tienen un instalador propio. Para instalarlosbasta con buscar "​Instalación de Matlab"​ o "​Instalación de Maple" en el menú de programas. O, alternativamente,​ ejecutar uno de los siguientes ​comandos''​install-matlab_R2012a.sh'',​ ''​install-matlab_R2011a.sh'',​ ''​install-maple16.sh'',​ ''​install-maple17.sh''​.+Ademáscuenta ​con los siguientes ​repositorios añadidos, sin instalar el software por defecto:
  
-==== Software disponible en repositorios ====+  * R (añadido o 19-04-2017) 
 +  * Docker (añadido o 01-05-2017)
  
-Primero, busca si el software que deseas está en repositorios. La forma más fiable es mediante línea de comandos:+===== Software adicional =====
  
-<​code>​apt-cache search programa</​code>​+Puedes solicitar la instalación de software adicional o ayuda para instalar software adicional a la Unidad de Gestión de Infraestructuras TIC, pero también puedes hacerlo por ti mismo si quieres.
  
-Aparecerá una lista de paquetes con una descripción cortaSi deseas una descripción más detallada de alguno de los paquetes, puedes escribir:+==== NVIDIA CUDA 8.0 ====
  
-<​code>​apt-cache show nome-do-paquete</code>+Antes de instalar CUDA 8.0, comprueba que tu gráfica sea compatible. Si no, puede que necesites instalar una versión anterior. 
 +Sigue los pasos descritos en https://​developer.nvidia.com/​cuda-downloads (Elixe //​Linux// ​-> //​x86_64// ​-//Ubuntu// -//16.04// -> //deb (network)//​).
  
-Para instalar ​un paquete, debes usar el siguiente comando:+Recuerda añadir estas líneas a tu ''​~/​.bashrc''​ (sólo para tu usuario) o en un archivo global llamado por ejemplo ''/​etc/​profile.d/​cuda.sh''​:
  
-<​code>​aptdcon ​-i nome-do-paquete</​code>​+<​code>​ 
 +export PATH=/​usr/​local/​cuda-8.0/​bin${PATH:​+:​${PATH}} 
 +export LD_LIBRARY_PATH=/​usr/​local/​cuda-8.0/​lib64${LD_LIBRARY_PATH:​+:​${LD_LIBRARY_PATH}} 
 +</​code>​
  
-Si deseas instalar varios paquetes a un tiempo, debes entrecomillarlos:​ 
  
-<​code>​aptdcon -i "​nombre-de-un-paquete nombre-de-otro-paquete"</​code>​+Tras hacer estos pasos, deberás reiniciar el sistema. Se tienes problemas, pide ayuda.
  
-Otras opciones interesantes de aptdcon son:+==== Matlab ====
  
-  * ''​-c''​: Actualiza ​la caché de paquetes disponibles +Para instalar la versión R2012a, ejecuta ​''​install-matlab_R2012a.sh'' ​en una terminal, o elige la opción ​''​Instalación de Matlab 2012a'' ​en el lanzador de aplicaciones.
-  * ''​-u nome-do-paquete''​: Actualiza un paquete +
-  * ''<​nowiki>​--</​nowiki>​safe-upgrade'':​ Actualiza todos los paquetes que se pueden actualizar +
-  * ''​-r nome-do-paquete'':​ Elimina un paquete+
  
-==== Otro software ====+La versión de 2017 aún no se puede instalar, pero se podrá próximamente.
  
-Si un software no está nos repositorios,​ pero ya se encuentra en algún repositorio compatible, bien en los propios repositorios de Ubuntu o en algún repositorio de terceros, podemos añadirlo a nuestros repositorios para que estén disponibles para todo el mundo. En ese caso, nos avisa mediante el [[https://​citius.usc.es/​dashboard/​enviar-incidencia|formulario de incidencias]]. 
  
-También puedes compilar e instalar desde código fuente los programas tú mismo, siempre y cuando pongas como //prefix// un directorio en el que puedas escribir, como en ''/​home/​local/​nombre.de.usuario''​. Normalmente,​ los programas permiten configurar un //prefix// de instalación personalizado. Consulta la documentación del programa.+==== Maple ====
  
 +Para instalar la versión 17, ejecuta ''​install-maple17.sh''​ en un terminal, o elige la opción ''​Instalación de Maple 17''​ en el lanzador de aplicaciones.
  
-===== Preguntas frecuentes =====+==== Docker ​====
  
-==== Quiero actualizar la Ubuntu 12.04 a la versión 14.04 ==== +El repositorio ​oficial ​ya está añadido, por lo que solo resta instalar ​el paquete ''​docker-ce''​.
- +
-Avisa en el formulario de incidencias. Indica la hora y día en que deseas que se haga la actualización. No perderás nada del home (ni local ni remoto), pero si perderás las personalizaciones específicas que pueda haber en tu equipo en la partición de sistema, y también las tareas de cron se las tuvieses. +
- +
-==== Establecer el idioma de la sesión ==== +
- +
-En Ubuntu 14.04 se puede establecer el idioma de la sesión desde la herramienta de «Soporte de idiomas». Puedes encontrarla en el menú Ubuntu. Para establecer un idioma por defecto, arrastra y suelta el idioma en la lista de idiomas instalados. Sólo están disponibles gallego, castellano e inglés y non es posible instalar nuevos idiomas. +
- +
-También se puede establecer el formato de fechas y números en la pestaña «Opciones regionales» de esa misma herramienta. +
- +
-==== Empathy no soporta las cuentas de XMPP/Jabber ==== +
- +
-Debes instalar el paquete ''​account-plugin-jabber''​ mediante el comando ''​aptdcon -i account-plugin-jabber''​. +
- +
-==== Puedo usar otros entornos además de Unity? ==== +
- +
-Sí, puedes instalar más entornos a través del Centro de Software de Ubuntu o con aptdcon. Están disponibles los siguientes entornos: +
- +
-  * GNOME Clásico +
-    * Instala el paquete ''​gnome-session-flashback''​. +
-  * KDE +
-    * Instala el paquete ''​escritorio-kde-minimo''​ si sólo deseas un escritorio muy básico. +
-    * Instala el paquete ''​escritorio-kde-basico''​ si además quieres aplicaciones básicas de KDE. +
-    * Instala el paquete ''​escritorio-kde-completo''​ si además quieres instalar todas las aplicaciones de KDE disponibles (cuidado, instala muchas aplicaciones). +
-  * LXDE +
-    * Instala el paquete ''​lxde''​ +
-  * I3-WM +
-    * Instala los paquetes ''​i3-wm'',​ ''​i3status''​ y ''​suckless-tools''​. +
-  * XFCE +
-    * Instala los paquetes ''​xfce4-session'',​ ''​xfce4-panel'',​ ''​shimmer-themes''​ y opcionalmente ''​xfce4-goodies''​. +
-    * Si deseas una experiencia más completa, debes instalar ''​xfce4-whiskermenu-plugin'',​ ''​xfce4-indicator-plugin''​ y ''​gtk-theme-config''​. +
- +
-==== ¿Cómo puedo instalar paquetes de LaTeX adicionales?​ ==== +
- +
-Puedes instalar cualquier paquete de TeXLive disponible en [[http://​www.ctan.org/​|CTAN]] en tu directorio de usuario. Primero debes instalar ''​xzdec'':​ +
- +
-<code bash>​aptdcon -i xzdec</​code>​ +
- +
-La primera vez, debes inicializar los directorios de TeXLive en tu usuario: +
- +
-<code bash>​tlmgr init-usertree</​code>​ +
- +
-Entonces, instala los paquetes deseados. Por ejemplo, para instalar [[http://​www.ctan.org/​pkg/​pgfgantt|pgfgantt]]:​ +
- +
-<​code>​tlmgr install pgfgantt</​code>​ +
- +
-==== No funciona Flash en Firefox, o aparece un aviso de seguridad ==== +
- +
-Primero, intenta actualizar manualmente el Flash. Abre una terminal y pon los siguientes comandos: +
- +
-<​code>​ aptdcon -c +
-aptdcon -u flashplugin-installer</​code>​ +
- +
-Si el problema persiste, es posible que el repositorio ​esté desactualizado. A veces Firefox marca el plugin de Flash como inseguro y no hay una alternativa actualizada,​ y debes esperar unos días a que aparezca. Si después de unos días todo sigue igual, avisa por si hubiese algún otro problema. +
- +
-==== Prefiero las barras de desplazamiento tradicionales,​ ¿puedo recuperarlas?​ ==== +
- +
-Esas barras de desplazamiento se llaman //Overlay Scrollbars//​. Para cambiarlas por las tradicionales basta con eliminar el paquete ''​overlay-scrollbar''​. Si más adelante quieres volver a usarlas, puedes volver a instalar el paquete. +
- +
-<​code>​aptdcon -r overlay-scrollbars</​code>​ +
- +
-==== Problemas imprimiendo documentos PDF ==== +
- +
-Algunos documentos, tras ser procesados por el lector de documentos evince, no se imprimen correctamente o dejan la impresora atascada. Una alternativa es utilizar el comando ''​lp'',​ que envía los documentos a la impresora sin procesar. Si no le pasas opciones, por defecto lp envía el documento a la impresora de tu planta y non imprime a doble cara. +
- +
-<​code>​lp -o sides=two-sided-long-edge archivo.pdf # imprime a doble cara +
-lp -P 12,15,17-20 archivo.pdf # imprime solamente páginas 12, 15 y 17 a 20 +
-lp -o number-up=4 -o fit-to-page -o number-up-layout=rltb archivo.pdf # imprime 4 páginas por hoja, de arriba a abajo y de izquierda a derecha, escalando para ocupar el máximo posible +
-lp -d ctprints1 ​ archivo.pdf # Imprime en la impresora del semisótano +
-lpstat -a # ver la lista de impresoras disponibles</​code>​ +
- +
-==== Unity queda atascado, ¿cómo podo recuperar el sistema sin reiniciar? ==== +
- +
-En algunas configuraciones,​ especialmente con poca memoria de vídeo, Unity (el entorno de ventanas) puede llegar a dejar de responder. Si eso ocurre, basta con intentar ejecutar el comando ''​unity-reload''​. Puedes intentar hacerlo pulsando ''​Alt+F2''​. Si no funciona, sal a una terminal pulsando ''​Control+Alt+F1'',​ haz login y ejecuta el comando desde ahí. Una vez ejecutado, vuelve a la sesión con ''​Alt+F7''​. +
- +
-==== Instalar paquetes de Ruby, Python y R en el directorio home ==== +
- +
-=== Ruby === +
- +
-El comando es el siguiente:​ +
- +
-<code bash>gem install --user-install nombre_paquete</​code>​ +
- +
-Antes de hacerlo por vez primera, necesitas instalar ''​ruby1.9.1-dev'':​ +
- +
-<code bash>​aptdcon -i ruby1.9.1-dev</​code>​ +
- +
-Al instalar la primera yema recibirás un warning porque debes añadir un directorio al PATH. Esto sólo debes hacerlo la primera vez. Por ejemplo: +
- +
-<​code>​WARNING: ​ You don't have /​home/​remoto/​jorge.suarez/​.gem/​ruby/​1.9.1/​bin in your PATH, +
-   gem executables will not run.</​code>​ +
- +
-Sólo tienes que ponerlo en tu archivo ''​bashrc''​ con este comando: +
- +
-<code bash>​echo "​export PATH=~/​.gem/​ruby/​1.9.1/​bin:​$PATH"​ >> ~/​.bashrc</​code>​ +
- +
-Para que tenga efecto en la sesión actual, ejecuta el comando entre comillas, o ejecuta ''​bash''​ para entrar en una nueva shell, o volver a entrar en la sesión. +
- +
-=== Python === +
- +
-La opción recomendada es instalar la distribución [[https://​www.continuum.io/​downloads#​_unix|Anaconda]]. Esta distribución se instala en un directorio del usuario y permite tener varias instalaciones con diferentes paquetes y distintas versiones de cada paquete. En el subdirectorio ''​bin''​ puedes encontrar todos los ejecutables típicos de python, así como el gestor de paquetes ''​conda''​. +
- +
-Alternativamente a Anaconda, puedes instalar paquetes en home usando ''​pip''​. +
- +
-Primero, necesitas instalar el paquete ''​python-dev'':​ +
- +
-<code bash>​aptdcon -i python-dev</​code>​ +
- +
-Importante, asegúrate de que tienes la última versión de ''​pip''​ instalada en home. +
- +
-<code bash>pip install --install-option="​--user"​ --upgrade pip</​code>​ +
- +
-Si recibes un error sobre ''​urllib3'',​ puedes solucionarlo actualizando el paquete ''​urllib3''​ con ''​pip'':​ +
- +
-<code bash>pip install --user --upgrade urllib3</​code>​ +
- +
-Si recibes un error de permiso denegado, puede que ya tengas instalado y actualizado ''​pip''​ a una versión reciente. Intenta actualizarlo con este comando en su lugar: +
- +
-<code bash>pip install --upgrade --user pip</​code>​ +
- +
-Ahora ya puedes instalar paquetes.  +
- +
-<code bash>pip install --user nome_paquete</​code>​ +
- +
-Si recibes alguna vez un error de que debes actualizar ''​pip''​puedes actualizarlo con el siguiente comando: +
- +
-<code bash>pip install --upgrade --user pip</​code>​ +
- +
-=== R === +
- +
-Antes de nada, crea un directorio en tu home chamado ''​R'':​ +
- +
-<code bash>​mkdir ~/​R</​code>​ +
- +
-Lanza R, y dentro ejecuta el comando de instalación de paquetes: +
- +
-<code R>R +
-install.packages("​nombre_paquete"​)</​code>​ +
- +
-Al hacerlo te preguntará si quieres hacerlo en ''​~/​R''​ al no poder escribir en ''/​usr/​local/​lib/​R''​. Contesta ''​y''​. El directorio se añadirá al path de bibliotecas e podrás cargarlas con normalidad. +
- +
-==== Al desbloquear la pantalla después de suspender, solicita dos veces la contraseña ==== +
- +
-Esto ocurre en el escritorio ​por defecto (Ubuntu) y es heredado de la configuración desde Ubuntu 12.04. Para solucionarlo,​ basta con ejecutar este comando en una terminal: +
- +
-<​code>​dconf reset -f /​org/​compiz/</​code>​ +
- +
-Tras cerrar sesión e iniciarla de nuevo, el problema debería desaparecer. Sólo se pierden algunas configuraciones avanzadas de escritorio que es poco probable que tocases. +
- +
-==== Al iniciar sesión el teclado cambia a inglés automáticamente ==== +
- +
-Esto es culpa de ''​ibus''​. Puedes desactivar ibus si no vas a usarlo (si no sabes qué es no lo estás usando). Para hacerlo, ve a //​Preferencias//​ » //Soporte de idiomas// y en el desplegable de método de entrada elige //​Ninguno//​. +
- +
-Si necesitas ''​ibus'',​ puedes solucionar este problema editando la configuración de ibus [[http://​askubuntu.com/​questions/​459617/​keyboard-layout-isnt-kept-upon-reboot|como se explica aquí]]. +
- +
-==== La firma de actas de la USC no funciona ==== +
- +
-Para que la firma de actas de la USC funcione, debes usar Firefox y tener instalado y actualizado el Java 8 de Oracle: +
- +
-<​code>​aptdcon -i oracle-java8-installer +
-aptdcon -i oracle-java8-set-default</​code>​ +
- +
-En Firefox, ve a //​Herramientas//​ » //​Complementos//​ y, en la sección Plugins, comprueba que tengas activado el //Java(TM) Plug-in 11.72.2// o superior y que tengas desactivado cualquier otro complemento de java, incluyendo el //​Icedtea//​. +
- +
-Abre el //Oracle Java 8 Plugin Control panel// ejecutando el comando ''​ControlPanel''​ y realiza los siguientes pasos: +
- +
-  - Borra los archivos temporales, en la primera pestaña, botón //​Preferencias//​ y luego en el nuevo diálogo, //Borrar archivos...//​. +
-  - Añade los siguientes sitios a la lista de excepciones en la pestaña de //​Seguridad//:​ +
-    * <​nowiki>​https://​aplicacions.usc.es/</​nowiki>​ +
-    * <​nowiki>​https://​sec-virtual.usc.es/</​nowiki>​ +
-    * <​nowiki>​https://​*.usc.es/</​nowiki>​ +
- +
-Asegúrate de tener instalado ​el paquete ​`libnss3`:​ +
- +
-<​code>​aptdcon -i libnss3</​code>​ +
- +
-Si al abrir el applet, no se quiere abrir con el ''​Oracle Java 8 Web Start'',​ sino con otro //Java Webstarter//​ distinto, dale a //Otro...// y elige la ruta al correcto: ''/​usr/​lib/​jvm/​java-8-oracle/​bin/​javaws''​. +
- +
- +
-Tras cargar el applet por primera vez, podrás recibir un error de que no puede acceder al almacén de certificados. Si es así, abre el archivo ''​~/​.esinatura/​mozilla.conf''​. Si el fichero no se crea, aquí tienes un fichero completo de ejemplo que puedes usar. Hay que corregir dos líneas, la que pone ''​library''​ y la que pone ''​nssArgs'':​+
  
 <​code>​ <​code>​
-name = NSS +sudo apt install docker-ce docker-compose
-slot = 2 +
-library = /​usr/​lib/​x86_64-linux-gnu/​nss/​libsoftokn3.so +
-nssArgs = "​configdir='/​home/​remoto/​jorge.suarez/​.mozilla/​firefox/​kek3dogy.default'​ certPrefix=''​ keyPrefix=''​ secmod='​secmod.db'​ flags=readOnly"​+
 </​code>​ </​code>​
  
-  * La que pone ''​library''​ por defecto apunta a ''/​usr/​lib/​nss/​libsoftokn3.so''​ que no existe, y hay que cambiarlo por ''/​usr/​lib/​x86_64-linux-gnu/​nss/​libsoftokn3.so''​.  +===== Problemas conocidos =====
-  * La que pone ''​nssArgs''​ apunta a un ''​configdir''​ que no existe, hay que corregir la ruta al directorio home y al perfil de Firefox correcto. +
- +
-Si aun así sigue sin funcionar, activa la //Java Console// en la pestaña //​Advanced//​ del //Oracle Java 8 Plugin Control panel//, vuelve a intentarlo y envía la salida de la consola para que podamos ver o problema. +
- +
-==== EL DNI electrónico no funciona ​====+
  
-De momento no funciona. En su lugar, puedes solicitar un certificado de la FNMT que hace la misma función pero puedes almacenarlo en el navegador, en lugar de almacenarlo en el DNI electrónico.+**Problema: No funciona el Wake on Lan**
  
-Los profesores (incluyendo doctorandos que tengan que dar clase) pueden solicitar ​el certificado a los gestores del centro ​de la Facultad de Matemáticas:​ +Si instalaste ​el escritorio MATE mediante ''​ubuntu-mate-desktop'',​ éste incluye ''​tlp'',​ un gestor ​de energía avanzado para portátiles que, entre otras cosas, deshabilita Wake on LanPuedes eliminar ''​tlp''​ o alternativamente configurar ''/​etc/​default/​tlp''​ estableciendo ''​WOL_DISABLE=N''​.
-  * Facultad de Matemáticas:​ Eduarda González - eduarda.gonzalez@usc.es - 13133+
  
  • es/centro/servizos/ubuntu_14.04_citius.txt
  • Última modificación: 2018/01/11 09:01
  • por diego.cougil